Assoc3dConstraintGroupAddConstraint Method
|
adds a new constraint of specified type with
given subentities to this constraints group
Namespace: Bricscad.Geometrical3dConstraints
Assembly: BrxMgd (in BrxMgd.dll) Version:
21.0.0.15598
Syntax
public Geometrical3dConstraint AddConstraint(
Geometrical3dConstraintConstraintType type,
FullSubentityPath[] arguments
)
Public Function AddConstraint (
type As Geometrical3dConstraintConstraintType,
arguments As FullSubentityPath()
) As Geometrical3dConstraint
public:
Geometrical3dConstraint^ AddConstraint(
Geometrical3dConstraintConstraintType type,
array<FullSubentityPath>^ arguments
)
member AddConstraint :
type : Geometrical3dConstraintConstraintType *
arguments : FullSubentityPath[] -> Geometrical3dConstraint
Parameters
- type
- Type: Bricscad.Geometrical3dConstraintsGeometrical3dConstraintConstraintType
constraint type
- arguments
- Type: Teigha.DatabaseServicesFullSubentityPath
subentities as FullSubentPath array
Return Value
Type:
Geometrical3dConstraint
return an object as created constraint, not NULL if succeeded
See Also