Assoc3dConstraintGroup Class

Inheritance Hierarchy
Namespace:  Bricscad.Geometrical3dConstraints
Assembly:  BrxMgd (in BrxMgd.dll) Version: 21.0.0.15598
Syntax
public class Assoc3dConstraintGroup : DisposableWrapper

The Assoc3dConstraintGroup type exposes the following members.

Properties
  Name Description
Public property BlockId
returns the owner block table record for this constraints group object
Public property Constraints
returns all Geometrical3dConstraint objects for this constraints group as array
Public property HasSketchPlane
returns whether this constraints group uses a sketch plane remark reserved for future use, returns false
Public property SketchPlane
returns the sketch plane for this constraints group Reserved for future use, not implemented yet
Public property Transient
returns whether this constraints group is transient or not remark reserved for future use, returns false
Top
Methods
  Name Description
Public method AddConstraint
adds a new constraint of specified type with given subentities to this constraints group
Public method DeleteConstraint
deletes the specified constraints object from this constraints group
Protected method DeleteUnmanagedObject (Overrides DisposableWrapperDeleteUnmanagedObject.)
Public method Evaluate
evaluate all constraints of this constraints group
Public method GetConstraintByNodeId
returns the constraint object as specified by its index (nodeId)
Top
See Also

©  Bricsys NV. All rights reserved.