Additions & Changes with
BricsCAD V21
- BLADE LISP IDE now better supports UTF-8/16 encoded Lisp source
files, on all platforms (Windows/Linux/Mac) - using the BOM with
all UTF-8/16 encoding is strongly suggested (or better
to use plain ANSI format, no encoding, if possible)
- Improvements and Additions
for DEScoder.exe v2.9
fixes issues with "Code Compression", and adds
active support for debugging;
.des files created with DEScoder.exe v2.9 are
backward compatible, created .des files can be loaded in all older
BricsCAD versions;
active debugging support applies to "DES
Container files" and "DES Single file" mode
- added new Generic Properties Functions
family to improve compatibility with AutoCAD
:
additionally, properties of BricsCAD's BIM
MCAD Civil TinSurface IFC2x3 IFC4 and external 3rd party
applications (those which support the C++ OPM API) can be queried +
modified
- added new TinSurface functions :
these functions allow to create, query and
modify the BricsCAD Civil TinSurface entities
- new SheetSetManager COM
interface has been added (compatible with
AutoCAD) :
due to a proper implementation, this
SheetSetManager COM interface is fully accessible by Lisp, VBA/VB,
and C/C++, from in-process and out-of-process application
code
- Extended VLA functions
(properties + methods) for Linux + Mac (also for "Fast-COM" under
Windows)
|
AddItems
|
Alignment
|
BasePoint
|
Boolean
|
|
Coordinate
|
DirectionVector
|
MajorAxis
|
MajorRadius
|
|
MinorAxis
|
MinorRadius
|
RadiusRatio
|
SecondPoint
|
|
SectionSolid
|
SliceSolid
|
Type
|
|
|
XVector
|
YVector
|
|
|
- Extended DOSLib
implementations for Linux + Mac
- New BricsCAD BIM interface
functions related to new "Spaces" concept
- Improvements and Additions
for BLADE
the Resources tab now always shows
the new LISP Core Functions
branch, using "Console", "Lisp/DES files" and
"BRX/NET files", documenting all loaded files, with all their
defined DEFUN functions and commands;
it also shows disabled DEFUN names (because
overwritten by another Lisp/BRX/NET file);
failing Lisp files are indicated in red color,
defined DEFUN functions are listed as loaded until error
occurred
Debugging is now significantly easier :
Lisp files (.lsp and .des) can be loaded
outside BLADE, and are still available for debugging; BLADE
automatically recognises the original source file, regardless
whether loaded outside or inside Debugger, and can actively use the
Lisp source
(also for DES encrypted Lisp files, once
created with DEScoder v2.9)