bim:get-material


(bim:get-material  name  [ global ])

Returns the definition data of the specified BIM material from the document library (default), or from the global library.

Arguments

name  (string) the case-sensitive name of the material to retrieve the definition data for

global  (optional, default NIL) if 'global' is specified and non-NIL, the material is retrieved from the global database, otherwise retrieved from the document-specific library

Return

list of definition data (in form of an assoc list using "key" and "value"), or NIL if the material does not exist in the specified library

Example

(setq data (bim:get-material "Gold"))
(("Name" . "Gold") ("Desc" . "") ("Comment" . "") ("Appearance" . "Gold") ("CH_Name" . "ANSI31") ("CH_Scale" . 1.0) ("CH_Angle" . 0.0) ("CH_Cross" . 0) ("CH_Anno" . 0) ("CH_Type" . 1) ("SH_Name" . "SOLID") ("SH_Scale" . 1.0) ("SH_Angle" . 0.0) ("SH_Cross" . 0) ("SH_Anno" . 0) ("SH_Type" . 1))

Remarks

all parameters with "CH_" prefix refer to the hatches for Cutting/section faces;
all parameters with "SH_" prefix refer to the hatches for Surface/elevation faces;

the items of the definition data can be modified, and then used by (bim:save-material) to create a new or modified BIM material;
the material name is case-sensitive !



©  Bricsys NV. All rights reserved.