EllipticalArc3d(Point3d, Vector3d, Vector3d, Double, Double) Constructor

Constructor for the EllipticalArc3d class. Creates an elliptical arc by the specified parameters.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public EllipticalArc3d(
        Point3d center,
        Vector3d majorAxis,
        Vector3d minorAxis,
        double majorRadius,
        double minorRadius
)

Parameters

center  Point3d
[in] The center of this elliptical arc.
majorAxis  Vector3d
[in] The major axis of this elliptical arc.
minorAxis  Vector3d
[in] The minor axis of this elliptical arc.
majorRadius  Double
[in] The major radius of this elliptical arc.
minorRadius  Double
[in] The minor radius of this elliptical arc.
See Also

©  Bricsys NV. All rights reserved.