SecurityParameters(String, String, String, String,
String, String, String, SecurityActions,
SecurityAlgorithm, UInt32, UInt32)
Constructor
|
Constructor for the SecurityParameters
class.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public SecurityParameters(
string password,
string providerName,
string subject,
string issuer,
string serialNumber,
string comment,
string timeServer,
SecurityActions actions,
SecurityAlgorithm algorithm,
uint keyLength,
uint providerType
)
Public Sub New (
password As String,
providerName As String,
subject As String,
issuer As String,
serialNumber As String,
comment As String,
timeServer As String,
actions As SecurityActions,
algorithm As SecurityAlgorithm,
keyLength As UInteger,
providerType As UInteger
)
public:
SecurityParameters(
String^ password,
String^ providerName,
String^ subject,
String^ issuer,
String^ serialNumber,
String^ comment,
String^ timeServer,
SecurityActions actions,
SecurityAlgorithm algorithm,
unsigned int keyLength,
unsigned int providerType
)
new :
password : string *
providerName : string *
subject : string *
issuer : string *
serialNumber : string *
comment : string *
timeServer : string *
actions : SecurityActions *
algorithm : SecurityAlgorithm *
keyLength : uint32 *
providerType : uint32 -> SecurityParameters
Parameters
- password String
- [in] Password string.
- providerName String
- [in] Name of the cryptography provider.
- subject String
- [in] Name of the certificate (digital ID) subject.
- issuer String
- [in] Name of the certificate (digital ID) issuer.
- serialNumber String
- [in] Serial number of the certificate (digital ID).
- comment String
- [in] Additional comment provided with the signature.
- timeServer String
- [in] Name of the time server used for timestamping.
- actions SecurityActions
- [in] Actions to perform.
- algorithm SecurityAlgorithm
- [in] Security algorithm. Only SecurityAlgorithm.RC4 is
supported.
- keyLength UInt32
- [in] Length of the encryption key. The value depends on the
providerName parameter.
- providerType UInt32
- [in] Encryption provider type.
See Also