SecurityParameters Class

This class represents the security parameters used by a database.
Inheritance Hierarchy
SystemObject
  Teigha.DatabaseServicesSecurityParameters

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class SecurityParameters

The SecurityParameters type exposes the following members.

Constructors
  Name Description
Public method SecurityParameters Obsolete.
Default constructor for the SecurityParameters class.
Public method SecurityParameters(String, String, String, String, String, String, String, SecurityActions, SecurityAlgorithm, UInt32, UInt32) Constructor for the SecurityParameters class.
Top
Properties
  Name Description
Public property Action Property that represents the security actions to perform.
Public property Algorithm Property that represents the security algorithm.
Public property Comment Property that represents the additional comment provided with the signature.
Public property Issuer Property that represents the name of the certificate (digital ID) issuer.
Public property KeyLength Property that represents the length of the encryption key.
Public property Password Property that represents the password string.
Public property ProviderName Property that represents the name of the cryptography provider.
Public property ProviderType Property that represents the encryption provider type.
Public property SerialNumber Property that represents the serial number of the certificate (digital ID).
Public property Subject Property that represents the name of the certificate (digital ID) subject.
Public property TimeServer Property that represents the name of the time server used for timestamping.
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ObjectEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides ObjectGetHashCode)
Public method ToString Returns an equivalent string representation of this object.
(Overrides ObjectToString)
Public method ToString(IFormatProvider) Returns an equivalent string representation of this object.
Top
Operators
  Name Description
Public operatorStatic member Equality(SecurityParameters, SecurityParameters) Equality operator for the SecurityParameters class.
Public operatorStatic member Inequality(SecurityParameters, SecurityParameters) Inequality operator for the SecurityParameters class.
Top
See Also

©  Bricsys NV. All rights reserved.