SectionSettingsSetLineWeight Method
|
Sets the lineweight of the specified
geometry.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SetLineWeight(
SectionType nSecType,
SectionGeometry nGeometry,
LineWeight nLineWeight
)
Public Sub SetLineWeight (
nSecType As SectionType,
nGeometry As SectionGeometry,
nLineWeight As LineWeight
)
public:
void SetLineWeight(
SectionType nSecType,
SectionGeometry nGeometry,
LineWeight nLineWeight
)
member SetLineWeight :
nSecType : SectionType *
nGeometry : SectionGeometry *
nLineWeight : LineWeight -> unit
Parameters
- nSecType SectionType
- [in] Section type.
- nGeometry SectionGeometry
- [in] Section geometry.
- nLineWeight LineWeight
- [in] Lineweight value.
Remarks
The nLineWeight
value can be one of the values from the
DatabaseServices::LineWeight enumeration:
Name |
Value |
Description |
ByBlock |
-2 |
Lineweight is defined by the owning block. |
ByLayer |
-1 |
Lineweight is defined by the owning layer. |
ByLineWeightDefault |
-1 |
Lineweight is defined by the LWDEFAULT system variable. |
LineweightNNN, where NNN is a 3-digit number |
Integer decimal number corresponding to lineweight name. |
Lineweight value in 100ths of a millimeter. |
See Also