LinkedTableDataSetDataLink(CellRange,
ObjectId, Boolean) Method
|
Sets the data link object ID for the specified
cell range.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void SetDataLink(
CellRange range,
ObjectId dataLinkId,
bool bUpdate
)
Public Overridable Sub SetDataLink (
range As CellRange,
dataLinkId As ObjectId,
bUpdate As Boolean
)
public:
virtual void SetDataLink(
CellRange^ range,
ObjectId dataLinkId,
bool bUpdate
)
abstract SetDataLink :
range : CellRange *
dataLinkId : ObjectId *
bUpdate : bool -> unit
override SetDataLink :
range : CellRange *
dataLinkId : ObjectId *
bUpdate : bool -> unit
Parameters
- range CellRange
- [in] Cell range.
- dataLinkId ObjectId
- [in] Data link object ID.
- bUpdate Boolean
- [in] Flag that indicates whether the data link should be
updated after being set.
Remarks
The method
generates the eNotThatKindOfClass
exception when the passed dataLinkId
parameter in not a DataLink object ID.
See Also