Cell
|
The CellRange type exposes the following members.
Name | Description | |
---|---|---|
![]() |
Alignment | |
![]() |
BackgroundColor | |
![]() |
Borders | |
![]() |
BottomRight | |
![]() |
BottomRightPlusOne | |
![]() |
BottomRow | |
![]() |
CanDeleteColumns | |
![]() |
CanDeleteRows | |
![]() |
CanInsertColumn | |
![]() |
CanInsertRow | |
![]() |
ContentColor | |
![]() |
ContentLayout | |
![]() |
DataFormat | |
![]() |
DataType | |
![]() |
IsBackgroundColorNone | |
![]() |
IsContentEditable | |
![]() |
IsEmpty | |
![]() |
IsFormatEditable | |
![]() |
IsLinked | |
![]() |
IsMergeAllEnabled | |
![]() |
IsMerged | |
![]() |
IsNull | |
![]() |
IsSingleCell | |
![]() |
Item | |
![]() |
LeftColumn | |
![]() |
Parent | Property that represents a parent object (table) of this cell range. |
![]() |
ParentTable | |
![]() |
RightColumn | |
![]() |
State | |
![]() |
Style | |
![]() |
TextHeight | |
![]() |
TextStyleId | |
![]() |
TopLeft | |
![]() |
TopRow |
Name | Description | |
---|---|---|
![]() |
ClearStyleOverrides | Clears the table style overrides from the cells. |
![]() ![]() |
Create | Creates a range of cells in a table. |
![]() |
DeleteContent | Deletes content from the cells. |
![]() |
Equals | Checks objects for equality. (Overrides ObjectEquals(Object)) |
![]() |
Finalize | Allows an object to try to free resources and perform other
cleanup operations before it is reclaimed by garbage
collection. (Inherited from Object) |
![]() |
GetCustomData | Returns the custom data value of the currently enumerated cell. |
![]() |
GetDataLink | Returns the data links for this range of cells. |
![]() |
GetEnumerator | Returns the enumerator for this range of cells. |
![]() |
GetHashCode | Retrieves the object hash code. (Overrides ObjectGetHashCode) |
![]() |
GetStyleOverrides | Returns the cell style overrides for this cell range. |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
IEnumerableGetEnumerator | Returns the enumerator for this range of cells. |
![]() |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object) |
![]() |
SetCustomData | Sets the custom data value for this cell range. |
![]() |
SetDataLink | Sets the data link for this cell range. |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
Name | Description | |
---|---|---|
![]() ![]() |
Equality(CellRange, CellRange) | Equality operator for the CellRange class. Checks whether cell ranges are equal. |
![]() ![]() |
Inequality(CellRange, CellRange) | Inequality operator for the CellRange class. Checks whether cell ranges are not equal. |
© Bricsys NV. All rights reserved. |