DatabaseResolveXrefs Method
|
Resolves existing external references for the
current working database.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void ResolveXrefs(
bool useThreadEngine,
bool doNewOnly
)
Public Sub ResolveXrefs (
useThreadEngine As Boolean,
doNewOnly As Boolean
)
public:
void ResolveXrefs(
bool useThreadEngine,
bool doNewOnly
)
member ResolveXrefs :
useThreadEngine : bool *
doNewOnly : bool -> unit
Parameters
- useThreadEngine Boolean
- [in] Flag that specifies whether to use the thread engine
during external reference resolution.
- doNewOnly Boolean
- [in] Flag that specifies whether to process only new external
references.
Remarks
If useThreadEngine is true,
the multi-thread engine is used to process the external references.
If doNewOnly is true, only unresolved
external reference records are processed. With this option the
multi-threaded engine is not used. This method does not lock the
document.
See Also