Database Class |
The Database type exposes the following members.
Name | Description | |
---|---|---|
![]() |
Database | Default constructor for the Database class. Creates a new database with a default set of objects (all tables, ModelSpace and PaperSpace blocks, etc.). |
![]() |
Database(Boolean, Boolean) | Constructor for the Database class. |
Name | Description | |
---|---|---|
![]() |
AbortDeepClone | Terminates a call to DeepCloneObjects() or WblockCloneObjects(). |
![]() |
AddDBObject | Adds an object to this database object, and returns its object ID. |
![]() |
ApplyPartialOpenFilters | Filters the model space entities of a database to only bring part of the drawing into memory. The filter applied is the intersection of entities in the view and the entities on the specified layers. Only entities both within the view and on the specified layers are brought into memory. |
![]() |
AttachXref | Attaches the external reference file specified by fileName to the database. As a result a new external reference BlockTableRecord is created. The new block table record's name is specified in blockName. Its object ID is returned. |
![]() |
Audit | Performs an audit operation on the header of this database object. |
![]() |
AuditXData | Performs an audit operation for the user data. Currently not implemented. |
![]() |
BindXrefs | |
![]() |
ClassDxfName | Retrieves the class DXF name for the specified class. |
![]() |
![]() |
CloseInput | Forces all data to be loaded from the input file associated with this database object, and closes the file. |
![]() |
![]() |
![]() |
CountHardReferences | Retrieves a count of hard references to each of the specified object IDs. |
![]() ![]() |
Create | |
![]() |
![]() |
DeepCloneObjects | Deep clones a set of objects and appends the clones to the specified owner object. |
![]() |
DetachXref | Detaches the specified external reference. |
![]() |
DisablePartialOpen | Forbids the partial open operation and forces the entire drawing database to be loaded. |
![]() |
DisableUndoRecording | Enables or disables recording of operations performed on this database. If disable==true, undo recording is turned off. |
![]() |
![]() |
DxfIn | Reads content of the specified .dxf file into this database. |
![]() |
DxfOut(String, Int32, Boolean) | Writes the contents of this database object to the specified output .dxf file. |
![]() |
DxfOut(String, Int32, DwgVersion) | Writes the contents of this database object to the specified output .dxf file. |
![]() |
DxfOut(StreamBuf, Int32, DwgVersion, Boolean) | Writes the contents of this database object to the specified output .dxf file. |
![]() |
![]() |
ForceWblockDatabaseCopy | Causes the next Database.Wblock() call on this database to copy the database. Currently not implemented. |
![]() ![]() |
FromAcadDatabase | Performs a conversion for the specified object of the AcadDatabase type to a database object. |
![]() ![]() |
GetAllDatabases | |
![]() |
GetDimensionStyleChildData | Retrieves the child dimension style data and dimension style object identifier. Currently not implemented. |
![]() |
GetDimensionStyleChildId | Retrieves the identifier of the child dimension style. Currently not implemented. |
![]() |
GetDimensionStyleParentId | Retrieves the identifier of the parent dimension style. Currently not implemented. |
![]() |
GetDimRecentStyleList | Retrieves identifiers of the most recently used dimension styles (up to six). Currently not implemented. |
![]() |
GetDimstyleData | Retrieves the database dimension variable values. |
![]() |
![]() |
GetHostDwgXrefGraph | Retrieves the XrefGraph object with the external reference tree of this database. |
![]() |
![]() |
GetNearestLineWeight | Requests a lineweight and returns the nearest C++ OdDb::LineWeight enum number for this database. For example, when the passed value is 8, the returned value is kLnWt009. Currently not implemented. |
![]() |
GetObjectId | Retrieves the object ID corresponding to the specified handle object in this database. |
![]() |
![]() |
GetSupportedDxfOutVersions | Retrieves an array that contains versions for the output operation. |
![]() |
GetSupportedSaveVersions | Retrieves an array that contains versions for the save operation. |
![]() |
![]() |
GetViewports | Retrieves identifiers of viewports. |
![]() |
GetVisualStyleList | Retrieves a collection of visual style names contained in the visual style dictionary. Currently not implemented. |
![]() |
![]() |
Insert(Matrix3d, Database, Boolean) | Copies the content of a specified database to this database. |
![]() |
Insert(String, Database, Boolean) | Copies the content of a specified database to this database. |
![]() |
Insert(String, String, Database, Boolean) | Copies the content of a specified database to this database. |
![]() ![]() |
IsObjectNonPersistent | Checks whether a specified object is not persistent. |
![]() |
IsValidLineWeight | Checks whether a specified lineweight value matches one of the predefined lineweights. |
![]() |
LoadLineTypeFile | Loads a linetype into this database object. |
![]() |
LoadMlineStyleFile | Loads an MLineStyle into the specified database object. |
![]() ![]() |
MarkObjectNonPersistent | Marks an object as non-persistent or persistent. |
![]() |
OverlayXref | Overlays the specified external reference file to the database. As a result a new external reference BlockTableRecord is created. |
![]() |
Purge(ObjectIdCollection) | Removes the object IDs from the specified array that are hard referenced in this database object. After method execution, the ids array contains only object ID entities of objects that are not currently hard-referenced and thus can safely be erased. |
![]() |
Purge(ObjectIdGraph) | Removes the nodes from the ID graph that are hard referenced in this database object. |
![]() |
![]() |
ReadDwgFile(IntPtr, Boolean, String) | Reads the contents of the drawing pointer by the drawingFile into this database object. |
![]() |
ReadDwgFile(String, FileShare, Boolean, String) | Reads the contents of the specified file into this database object. |
![]() |
ReadDwgFile(String, FileOpenMode, Boolean, String) | Reads the contents of the specified file name into this database object. |
![]() |
ReadDwgFile(IntPtr, Boolean, String, AuditInfo, Boolean) | Reads the contents of the drawing pointer by the drawingFile into this database object. |
![]() |
ReadDwgFile(String, FileShare, Boolean, String, Boolean) | Reads the contents of the specified file into this database object. |
![]() |
ReadDwgFile(String, FileOpenMode, Boolean, String, Boolean) | Reads the contents of the specified file into this database object. |
![]() |
ReadDwgFileFromMemory | Reads the contents of the file, represented by array of bytes, into this database object. |
![]() |
ReclaimMemoryFromErasedObjects | Deletes the objects related to the passed object identifiers and performs corresponding cleaning operations. Currently not implemented. |
![]() |
Redo | Performs a redo operation on this database object. |
![]() |
ReloadXrefs | Reloads the external references for the specified xrefIds identifiers in the block table record. |
![]() |
ResolveXrefs | Resolves existing external references for the current working database. |
![]() |
RestoreForwardingXrefSymbols | This method must be used with RestoreOriginalXrefSymbols() and should be wrapped around all code with plans to edit and/or save external reference databases. |
![]() |
RestoreOriginalXrefSymbols | Returns the database to its modified state (before any original state restoration) by redoing modifications. |
![]() |
Save | Saves content of the currently active database. The file is saved with the original file name, type and version. |
![]() |
SaveAs(String, DwgVersion) | Saves content of the currently active database according to the passed file name and version. |
![]() |
SaveAs(String, SecurityParameters) | Saves content of the currently active database according to the passed file name and security parameters. |
![]() |
SaveAs(StreamBuf, DwgVersion, Boolean) | Saves content of the currently active database according to the passed arguments. |
![]() |
SaveAs(String, DwgVersion, Boolean) | Saves content of the currently active database according to the passed file name and version. |
![]() |
SaveAs(String, Boolean, DwgVersion, SecurityParameters) | Saves content of the currently active database according to the passed arguments. |
![]() |
SaveAs(String, DwgVersion, Boolean, Int32) | Saves content of the currently active database according to the passed arguments. |
![]() |
SaveAs(StreamBuf, SaveType, DwgVersion, Boolean, Int32) | Saves content of the currently active database according to the passed arguments. |
![]() |
SaveAs(String, SaveType, DwgVersion, Boolean, Int32) | Saves content of the currently active database according to the passed arguments. |
![]() |
SetDimstyleData | Copies the dimension style data from the specified dimension style table record into this database object. |
![]() |
SetTimeZoneAsUtcOffset | Sets the current time zone for this database using an offset from UTC. For example, the offset for the Brasilia Time Zone is -3.0. Currently not implemented. |
![]() |
SetWorldPaperspaceUcsBaseOrigin | Sets the new default origin point the the new paper space for the passed view. |
![]() |
SetWorldUcsBaseOrigin | Sets the new default origin point the the new model space for the passed view. |
![]() |
StartUndoRecord | Starts undo recording of this database object. |
![]() |
TimeZoneDescription | Retrieves a description of a time zone. |
![]() |
TimeZoneOffset | Retrieves the offset in hours from the time zone passed in, from UTC. For example, the offset for Brasilia time is -3.0. |
![]() |
![]() |
TryGetObjectId | Searches for an object identifier by the specified handle. |
![]() |
Undo | Performs an undo operation on this database object. |
![]() |
UnloadXrefs | Unloads the external references from the block table record which correspond to the passed identifiers. |
![]() |
UpdateExt | Recalculates the extents of this database object. |
![]() |
Wblock | Clones the entire contents of this database to a new database. |
![]() |
Wblock(ObjectId) | Clones the specified block table record of this database to a new database. |
![]() |
Wblock(ObjectIdCollection, Point3d) | Clones the specified block table record of this database to a new database. |
![]() |
Wblock(Database, ObjectIdCollection, Point3d, DuplicateRecordCloning) | |
![]() |
WblockCloneObjects | Uses the deep cloning mechanism to write specified objects of this database to the new database. The objects can be taken from different source databases and must match the type of owner specified. |
![]() |
WorldPaperspaceUcsBaseOrigin | Retrieves the default origin point of the new paper space for the passed view. |
![]() |
WorldUcsBaseOrigin | Retrieves the default origin point of the new model space for the passed view. |
![]() |
![]() |
XBindXrefs |
Name | Description | |
---|---|---|
![]() |
ExportCivil3DToNative | (Defined by Civil3DConversionExtensions) |
![]() |
GetCivilFileFormatManager | (Defined by FileFormatExtensions) |
![]() |
GetCivilGisPropertyManager | (Defined by GisPropertyManagerExtension) |
![]() |
GetCivilPointGroupManager | (Defined by PointGroupExtension) |
![]() |
GetCivilPointLabelStylesManager | (Defined by StyleExtension) |
![]() |
GetCivilSurfaceContourLabelStylesManager | (Defined by StyleExtension) |
![]() |
GetCivilSurfaceElevationLabelStylesManager | (Defined by StyleExtension) |
![]() |
GetCivilSurfaceSlopeLabelStylesManager | (Defined by StyleExtension) |
![]() |
GetCivilSymbolStylesManager | (Defined by StyleExtension) |
![]() |
SaveBimProfile | (Defined by BIMProfileExtension) |
© Bricsys NV. All rights reserved. |