Matrix3dAlignCoordinateSystem
Method
|
Returns the matrix that maps the coordinate
system defined by the fromOrigin origin and the fromXAxis,
fromYAxis and fromZAxis axes, to the coordinate system defined by
the toOrigin origin and the toXAxis, toYAxis and toZAxis
axes.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public static Matrix3d AlignCoordinateSystem(
Point3d fromOrigin,
Vector3d fromXAxis,
Vector3d fromYAxis,
Vector3d fromZAxis,
Point3d toOrigin,
Vector3d toXAxis,
Vector3d toYAxis,
Vector3d toZAxis
)
Public Shared Function AlignCoordinateSystem (
fromOrigin As Point3d,
fromXAxis As Vector3d,
fromYAxis As Vector3d,
fromZAxis As Vector3d,
toOrigin As Point3d,
toXAxis As Vector3d,
toYAxis As Vector3d,
toZAxis As Vector3d
) As Matrix3d
public:
static Matrix3d AlignCoordinateSystem(
Point3d fromOrigin,
Vector3d fromXAxis,
Vector3d fromYAxis,
Vector3d fromZAxis,
Point3d toOrigin,
Vector3d toXAxis,
Vector3d toYAxis,
Vector3d toZAxis
)
static member AlignCoordinateSystem :
fromOrigin : Point3d *
fromXAxis : Vector3d *
fromYAxis : Vector3d *
fromZAxis : Vector3d *
toOrigin : Point3d *
toXAxis : Vector3d *
toYAxis : Vector3d *
toZAxis : Vector3d -> Matrix3d
Parameters
- fromOrigin Point3d
- [in] Origin of the initial coordinate system.
- fromXAxis Vector3d
- [in] X-axis of the initial coordinate system.
- fromYAxis Vector3d
- [in] Y-axis of the initial coordinate system.
- fromZAxis Vector3d
- [in] Z-axis of the initial coordinate system.
- toOrigin Point3d
- [in] Origin of the target coordinate system.
- toXAxis Vector3d
- [in] X-axis of the target coordinate system.
- toYAxis Vector3d
- [in] Y-axis of the target coordinate system.
- toZAxis Vector3d
- [in] Z-axis of the target coordinate system.
Return Value
Matrix3d
See Also