EllipticalArc3dSet(Point3d, Vector3d, Vector3d, Double, Double, Double, Double) Method

Sets the specified center, axes, radii and angles for this arc.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public void Set(
        Point3d center,
        Vector3d majorAxis,
        Vector3d minorAxis,
        double majorRadius,
        double minorRadius,
        double startAngle,
        double endAngle
)

Parameters

center  Point3d
[in] Center of this arc.
majorAxis  Vector3d
[in] Vector that defines the major axis of this arc.
minorAxis  Vector3d
[in] Vector that defines the minor axis of this arc.
majorRadius  Double
[in] A point on the axis of symmetry.
minorRadius  Double
[in] Axis of symmetry (rotation).
startAngle  Double
[in] Start angle of this elliptical arc.
endAngle  Double
[in] End angle of this elliptical arc.
See Also

©  Bricsys NV. All rights reserved.