DatabaseReadDwgFileFromMemory
Method
|
Reads the contents of the file, represented by
array of bytes, into this database object.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void ReadDwgFileFromMemory(
byte[] drawingFileByteArray,
bool allowCPConversion,
string password
)
Public Sub ReadDwgFileFromMemory (
drawingFileByteArray As Byte(),
allowCPConversion As Boolean,
password As String
)
public:
void ReadDwgFileFromMemory(
array<unsigned char>^ drawingFileByteArray,
bool allowCPConversion,
String^ password
)
member ReadDwgFileFromMemory :
drawingFileByteArray : byte[] *
allowCPConversion : bool *
password : string -> unit
Parameters
- drawingFileByteArray Byte
-
- allowCPConversion Boolean
- [in] Flag that specifies whether codepage conversion should
occur silently.
- password String
- [in] Password for a file.
Remarks
Pieces of the
drawing are read in only as needed. So, the drawing file is left
open until the database object is deleted. The method attempts to
open files with read access. The allowCPConversion argument specifies whether to
automatically perform a default conversion from the drawing
codepage to the system codepage if corresponding files for
conversion are not available (which might cause loss of data). If
allowCPConversion is false, you are asked if conversion should be
performed, otherwise conversion is performed silently.
See Also