Adds the specified scene graph to this
Viewport object.
Namespace: Teigha.GraphicsSystem
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual bool Add(
Drawable drawable
)
Public Overridable Function Add (
drawable As Drawable
) As Boolean
public:
virtual bool Add(
Drawable^ drawable
)
abstract Add :
drawable : Drawable -> bool
override Add :
drawable : Drawable -> bool
Parameters
- drawable Drawable
- [in] Root of the scene graph.
Return Value
Boolean
Remarks
This function is
intended to be used as follows: 1. Construct a scene graph of
OdGiDrawable objects. Each object draws its children using
Geometry::draw(). 2. With this function, add the root of the scene
graph.
See Also