Drawable Class

This class wraps the OdGiDrawable which is the base class for all graphical objects, both transient and persistent. This interface must be implemented by all graphical objects. Such objects are capable of vectorizing themselves within the ODA Platform.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceDrawable
          Teigha.DatabaseServicesDBObject

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class Drawable : RXObject

The Drawable type exposes the following members.

Constructors
  Name Description
Protected method Drawable Initializes a new instance of the Drawable class
Protected method Drawable(IntPtr, Boolean) Initializes a new instance of the Drawable class
Top
Properties
  Name Description
Public property Bounds  
Public property DrawableType  
Public property Id  
Public property IsPersistent  
Top
Methods
  Name Description
Public method RegenSupportFlags  
Public method SetAttributes Sets the vectorization attributes of this object, and returns its attribute flags.
Protected method SubRegenSupportFlags  
Protected method SubSetAttributes  
Protected method SubViewportDraw  
Protected method SubViewportDrawLogicalFlags  
Protected method SubWorldDraw  
Public method ViewportDraw Creates a viewport-dependent geometric representation of this object.
Public method ViewportDrawLogicalFlags Retrieves the setAttributes flags for the current viewportDraw.
Public method WorldDraw Creates a viewport-independent geometric representation of this object.
Top
See Also

©  Bricsys NV. All rights reserved.