PlanarEntityGetCoordinateSystem Method
|
Returns the orthonormal canonical coordinate
system of this plane.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public CoordinateSystem3d GetCoordinateSystem()
Public Function GetCoordinateSystem As CoordinateSystem3d
public:
CoordinateSystem3d GetCoordinateSystem()
member GetCoordinateSystem : unit -> CoordinateSystem3d
Return Value
CoordinateSystem3d
Remarks
The orthonormal
canonical coordinate system associated with a plane is defined as
follows. Parameter Description Computed as origin Origin of plane.
origin axis1 A unit vector in the plane. uAxis.normal() axis2 A
unit vector in the plane perpendicular to axis1.
normal.crossProduct(axis1)
See Also