PlanarEntity Class

This class wraps the OdGePlanarEnt class which is the base class for all OdGe planes in 3D space. A parametric point on the plane with parameters u and v maps to the point S(u,v) as follows: S(u,v) = originOfPlanarEntity + (u * uAxis) + (v * vAxis) uAxis and vAxis need not be normalized or perpendicular, but they must not be colinear. Parameter Description Computed as origin Origin of plane. origin axis1 A unit vector in the plane. uAxis.normal() axis2 A unit vector perpendicular to the plane. uAxis.crossProduct(vAxis).normal() The plane equation for a plane is as follows:
C#
a * X + b * Y + c * Z + d = 0
For more information, see Working with Planes.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometrySurface
          Teigha.GeometryPlanarEntity
            Teigha.GeometryBoundedPlane
            Teigha.GeometryPlane

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class PlanarEntity : Surface

The PlanarEntity type exposes the following members.

Properties
  Name Description
Public property Coefficients Property that represents coefficients for the plane equation for this plane. The plane equation for this plane is as follows:
C#
a * x + b * y + c * z + d = 0
Public property Normal Property that represents a normal vector to this planar entity.
Public property PointOnPlane Property that represents an arbitrary point on this planar entity.
Top
Methods
  Name Description
Public method ClosestPointToLinearEntity(LinearEntity3d) Calculates the point on this planar entity that is closest to the specified line and the point on the specified line that is closest to this planar entity.
Public method ClosestPointToLinearEntity(LinearEntity3d, Tolerance) Calculates the point on this planar entity that is closest to the specified line and the point on the specified line that is closest to this planar entity.
Public method ClosestPointToPlanarEntity(PlanarEntity) Calculates the point on this planar entity that is closest to the specified planar entity and the point on the specified planar entity that is closest to this planar entity.
Public method ClosestPointToPlanarEntity(PlanarEntity, Tolerance) Calculates the point on this planar entity that is closest to the specified planar entity and the point on the specified planar entity that is closest to this planar entity.
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method Equals
(Overrides DisposableWrapperEquals(Object))
Public method GetCoordinateSystem Returns the orthonormal canonical coordinate system of this plane.
Public method IntersectWith(LinearEntity3d) Calculates an intersection point with the specified line.
Public method IntersectWith(LinearEntity3d, Tolerance) Calculates an intersection point with the specified line.
Public method IsCoplanarTo(PlanarEntity) Checks whether the specified planar entity is coplanar to this entity.
Public method IsCoplanarTo(PlanarEntity, Tolerance) Checks whether the specified planar entity is coplanar to this entity.
Public method IsParallelTo(LinearEntity3d) Checks whether the specified linear entity is parallel to this entity.
Public method IsParallelTo(PlanarEntity) Checks whether the specified planar entity is parallel to this entity.
Public method IsParallelTo(LinearEntity3d, Tolerance) Checks whether the specified linear entity is parallel to this entity.
Public method IsParallelTo(PlanarEntity, Tolerance) Checks whether the specified planar entity is parallel to this entity.
Public method IsPerpendicularTo(LinearEntity3d) Checks whether the specified linear entity is perpendicular to this entity.
Public method IsPerpendicularTo(PlanarEntity) Checks whether the specified planar entity is perpendicular to this entity.
Public method IsPerpendicularTo(LinearEntity3d, Tolerance) Checks whether the specified linear entity is perpendicular to this entity.
Public method IsPerpendicularTo(PlanarEntity, Tolerance) Checks whether the specified planar entity is perpendicular to this entity.
Top
See Also

©  Bricsys NV. All rights reserved.