DatabaseOverlayXref Method
|
Overlays the specified external reference file
to the database. As a result a new external reference
BlockTableRecord is created.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public ObjectId OverlayXref(
string fileName,
string blockName
)
Public Function OverlayXref (
fileName As String,
blockName As String
) As ObjectId
public:
ObjectId OverlayXref(
String^ fileName,
String^ blockName
)
member OverlayXref :
fileName : string *
blockName : string -> ObjectId
Parameters
- fileName String
- [in] External reference file path name.
- blockName String
- [in] External reference block name symbol to use.
Return Value
ObjectId
Identifier of a newly created BlockTableRecord.
Remarks
The document is
not locked during the external reference overlay operation, and a
new instance of the BlockReference instance class is not
created.
See Also