Introduces the specified object into the
vectorization context.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public abstract bool Draw(
Drawable value
)
Public MustOverride Function Draw (
value As Drawable
) As Boolean
public:
virtual bool Draw(
Drawable^ value
) abstract
abstract Draw :
value : Drawable -> bool
Parameters
- value Drawable
- [in] Handle to the drawable object.
Return Value
Boolean
true. This method also throws a corresponding exception if it
fails.
Remarks
Implementations of
this method are expected to do the following: * Call
Drawable.subSetAttributes to set attribute information for the
object. * Call subWorldDraw on the drawable object to vectorize it
into this context. * If subWorldDraw returns false, call
subViewportDraw for each viewport.
See Also