Solid3dRemoveFaces
Method
|
Removes the specified faces from the
solid.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void RemoveFaces(
SubentityId[] subentityIds
)
Public Overridable Sub RemoveFaces (
subentityIds As SubentityId()
)
public:
virtual void RemoveFaces(
array<SubentityId>^ subentityIds
)
abstract RemoveFaces :
subentityIds : SubentityId[] -> unit
override RemoveFaces :
subentityIds : SubentityId[] -> unit
Parameters
- subentityIds SubentityId
- [in] Face's subentity ID in the solid.
Remarks
After removing the
specified faces, the adjacent faces enlarge to fill the gaps. This
method implements gap filling only if there is no other solution
using adjacent faces. If adjacent faces can't be used, the method
leaves the solid unmodified. Removing faces can cause the solid to
become invalid in some cases. This method is implemented only for
the Spatial modeler.
See Also