SubentityId Structure

This class implements subentity ID objects for entity objects in a database. An entity object can consist of any number of graphical subentities. Subentity type must be one of the following: NameValueNull 0 Face 1 Edge 2 Vertex 3 MlineCache 4 Class 5 Each SubentityId object is created from a Subentity type and an index.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.DatabaseServicesSubentityId

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct SubentityId

The SubentityId type exposes the following members.

Constructors
  Name Description
Public method SubentityId(RXClass, Int64) Obsolete.
Constructor for the SubentityId class.
Public method SubentityId(RXClass, IntPtr) Constructor for the SubentityId class.
Public method SubentityId(SubentityType, Int64) Obsolete.
Constructor for the SubentityId class.
Public method SubentityId(SubentityType, IntPtr) Constructor for the SubentityId class.
Top
Properties
  Name Description
Public property Index Obsolete.
Property that represents the subentity index as an integer value.
Public property IndexPtr Property that represents the subentity index as IntPtr.
Public propertyStatic member Null Property that represents the NULL subentity ID.
Public property Type Property that represents the subentity type.
Public property TypeClass Property that represents the class type of a subentity when the subentity type == SubentityType.Class.
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Top
Operators
  Name Description
Public operatorStatic member Equality(SubentityId, SubentityId) Equality operator for the SubentityId class. Checks whether the subentity identifiers are equal.
Public operatorStatic member Inequality(SubentityId, SubentityId) Inequality operator for the SubentityId class. Checks whether the subentity identifiers are not equal.
Top
See Also

©  Bricsys NV. All rights reserved.