SubDMeshExtrudeFaces(FullSubentityPath, Point3dCollection,
Double) Method
|
Extrudes faces along the given direction and
with a given taper angle.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void ExtrudeFaces(
FullSubentityPath[] paths,
Point3dCollection alongPath,
double taper
)
Public Sub ExtrudeFaces (
paths As FullSubentityPath(),
alongPath As Point3dCollection,
taper As Double
)
public:
void ExtrudeFaces(
array<FullSubentityPath>^ paths,
Point3dCollection^ alongPath,
double taper
)
member ExtrudeFaces :
paths : FullSubentityPath[] *
alongPath : Point3dCollection *
taper : float -> unit
Parameters
- paths FullSubentityPath
- [in] Flag that specifies whether to convert to a smooth
surface. If false, converts to a faceted surface.
- alongPath Point3dCollection
- [in] Array of points, which describes the path, along which the
faces are extruded.
- taper Double
- [in] Taper angle of extrusion.
See Also