FullSubentityPath Structure

This class uniquely defines subentities within in a database. Each instance of this class consists of a SubentId object and an ordered array of Object IDs. The SubentId consists the index and subentType of the object. The array of Object IDs defines the path to the entity containing the specified subentity from the outermost entity (in PaperSpace or ModelSpace).
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.DatabaseServicesFullSubentityPath

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct FullSubentityPath

The FullSubentityPath type exposes the following members.

Constructors
  Name Description
Public method FullSubentityPath Constructor for the FullSubentityPath class.
Top
Properties
  Name Description
Public property IsNull Property that indicates this full subentity path is a NULL subentity path.
Public propertyStatic member Null Property that represents the NULL full subentity path.
Public property SubentId Property that represents the subentity Id for which the path is constructed.
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method GetObjectIds Returns an array of Object Ids of entities that define the path from the outermost entity to the entity that contains the subentity.
Top
Operators
  Name Description
Public operatorStatic member Equality(FullSubentityPath, FullSubentityPath) Equality operator for the FullSubentityPath class. Checks whether objects are equal.
Public operatorStatic member Inequality(FullSubentityPath, FullSubentityPath) Inequality operator for the FullSubentityPath class. Checks whether objects are not equal.
Top
See Also

©  Bricsys NV. All rights reserved.