ModelsetSectioning(Point3dCollection,
Vector3d, Double, Double) Method
|
Sets the active sectioning for this Model
object. The sectioning is capped vertically using the specified top
and bottom heights. After specifying the sectioning, it should be
enabled with the EnableSectioning property.
Namespace: Teigha.GraphicsSystem
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual bool setSectioning(
Point3dCollection points,
Vector3d upVector,
double dTop,
double dBottom
)
Public Overridable Function setSectioning (
points As Point3dCollection,
upVector As Vector3d,
dTop As Double,
dBottom As Double
) As Boolean
public:
virtual bool setSectioning(
Point3dCollection^ points,
Vector3d upVector,
double dTop,
double dBottom
)
abstract setSectioning :
points : Point3dCollection *
upVector : Vector3d *
dTop : float *
dBottom : float -> bool
override setSectioning :
points : Point3dCollection *
upVector : Vector3d *
dTop : float *
dBottom : float -> bool
Parameters
- points Point3dCollection
- [in] Array of co-planar points specifying a sectioning
region.
- upVector Vector3d
- [in] Vector that specifies the orientation of the plane that
contains points.
- dTop Double
- [in] Specifies the top capping height of the sectioning.
- dBottom Double
- [in] Specifies the bottom capping height of the
sectioning.
Return Value
Boolean
true if the specified sectioning is
valid. Returns false if the specified sectioning is invalid or
malformed.
Remarks
If the last point
of the points array is equal to the first point of this array, the
sectioning region is closed. The upVector is used to specify the
clipped and unclipped sides of the sectioning. The unclipped side
is determined by the direction of the cross product of the first
line segment defined by the point array and the upVector.
See Also