Model Class |
The Model type exposes the following members.
Name | Description | |
---|---|---|
![]() |
![]() |
Background | |
![]() |
EnableLightsInBlocks | |
![]() |
EnableLinetypes | |
![]() |
EnableSectioning | |
![]() |
EnableViewExtentsCalculation | |
![]() |
![]() |
RenderModeOverride | |
![]() |
RenderType | |
![]() |
SectioningVisualStyle | |
![]() |
Selectable | |
![]() |
Transform | |
![]() |
![]() |
ViewClippingOverride | |
![]() |
ViewSectioningOverride | |
![]() |
VisualStyle | |
![]() |
VisualStyleId |
Name | Description | |
---|---|---|
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Highlight | Highlights the specified entity in this Model object. |
![]() |
![]() |
Invalidate(InvalidationHint) | Invalidates the specified cached data contained in this Model object. |
![]() |
Invalidate(View) | Invalidates the specified cached data contained in this Model object. |
![]() |
![]() |
![]() |
OnAdded(Drawable, Int64) | Notification method called whenever a Drawable object is added to this Model object. |
![]() |
OnAdded(Drawable, Drawable) | Notification method called whenever a drawable object is added to this Model object. |
![]() |
OnErased(Drawable, Int64) | Notification function called whenever a Drawable object is erased from this Model object. |
![]() |
OnErased(Drawable, Drawable) | Notification function called whenever a Drawable object is erased from this Model object. |
![]() |
OnModified(Drawable, Int64) | Notification function called whenever a Drawable object is modified in this Model object. |
![]() |
OnModified(Drawable, Drawable) | Notification function called whenever a drawable object is modified in this Model object. |
![]() |
OnUnerased(Drawable, Int64) | Notification function called whenever a Drawable object is unerased from this Model object. |
![]() |
OnUnerased(Drawable, Drawable) | Notification function called whenever a drawable object is unerased from this Model object. |
![]() |
![]() |
setSectioning(Point3dCollection, Vector3d) | Sets the active sectioning for this Model object. After specifying the sectioning, it should be enabled with the EnableSectioning property. |
![]() |
setSectioning(Point3dCollection, Vector3d, Double, Double) | Sets the active sectioning for this Model object. The sectioning is capped vertically using the specified top and bottom heights. After specifying the sectioning, it should be enabled with the EnableSectioning property. |
![]() |
![]() |
© Bricsys NV. All rights reserved. |