Searches for which element of the Mline object
contains the point.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public int Element(
Point3d pt
)
Public Function Element (
pt As Point3d
) As Integer
public:
int Element(
Point3d pt
)
member Element :
pt : Point3d -> int
Parameters
- pt Point3d
-
Return Value
Int32
the index number of the element that contains the point, if
successful. If not successful, returns -1.
Remarks
If an element is
not found that directly contains the point and the Mline object is
not closed, the ends of the MLine object are virtually extended to
see if the point lies in the path of any element.
See Also