SectionSettingsLineWeight
Method
|
Returns the lineweight of the specified
geometry.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public LineWeight LineWeight(
SectionType nSecType,
SectionGeometry nGeometry
)
Public Function LineWeight (
nSecType As SectionType,
nGeometry As SectionGeometry
) As LineWeight
public:
LineWeight LineWeight(
SectionType nSecType,
SectionGeometry nGeometry
)
member LineWeight :
nSecType : SectionType *
nGeometry : SectionGeometry -> LineWeight
Parameters
- nSecType SectionType
- [in] Section type.
- nGeometry SectionGeometry
- [in] Section geometry.
Return Value
LineWeight
One of the values from the DatabaseServices::LineWeight enumeration
that represents the following:
Name |
Value |
Description |
ByBlock |
-2 |
Lineweight is defined by the owning block. |
ByLayer |
-1 |
Lineweight is defined by the owning layer. |
ByLineWeightDefault |
-1 |
Lineweight is defined by the LWDEFAULT system variable. |
LineweightNNN, where NNN is a 3-digit number |
Integer decimal number corresponding to the lineweight
name. |
Lineweight value in 100ths of a millimeter. |
See Also