NurbCurve3d(Point3dCollection, Vector3d, Vector3d, Boolean, Boolean) Constructor

Constructor for the NurbCurve3d class. Constructs a 3D curve interpolating a given array of 3D points and using given derivatives at the start point and endpoint.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public NurbCurve3d(
        Point3dCollection fitPoints,
        Vector3d startTangent,
        Vector3d endTangent,
        bool startTangentDefined,
        bool endTangentDefined
)

Parameters

fitPoints  Point3dCollection
[in] Array of 3D points through which to fit the curve.
startTangent  Vector3d
[in] Start tangent vector.
endTangent  Vector3d
[in] End tangent vector.
startTangentDefined  Boolean
[in] Flag indicating whether startTangent should be used.
endTangentDefined  Boolean
[in] Flag indicating whether endTangent should be used.
Remarks
If startTangentDefined is 0, startTangent is ignored and the constructor computes the start tangent vector. The same is true for endTangentDefined.
See Also

©  Bricsys NV. All rights reserved.