LeaderAnnotationOffset Property
|
Property that represents the annotation offset
of this leader entity. The annotation offset determines the final
leader endpoint of this leader entity. Annotation typeFinal leader
endpointMText annotationOffset() + MText.location() ±
Vector3d(dimgap(), 0, 0) FeatureControlFrame annotationOffset() +
FeatureControlFrame.location() ± Vector3d(dimgap(), 0, 0) BlockRef
annotationOffset() + OdDbBlockReference.position() NoAnnotation
lastVertex()
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual Vector3d AnnotationOffset { get; set; }
Public Overridable Property AnnotationOffset As Vector3d
Get
Set
public:
virtual property Vector3d AnnotationOffset {
Vector3d get ();
void set (Vector3d value);
}
abstract AnnotationOffset : Vector3d with get, set
override AnnotationOffset : Vector3d with get, set
Property Value
Vector3d
See Also