CubicSplineCurve3d(Point3dCollection,
Vector3d, Vector3d) Constructor
|
Constructor for the CubicSplineCurve3d class.
Creates a cubic spline curve with the passed start and end
derivatives, and points.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public CubicSplineCurve3d(
Point3dCollection points,
Vector3d startDerivative,
Vector3d endDerivative
)
Public Sub New (
points As Point3dCollection,
startDerivative As Vector3d,
endDerivative As Vector3d
)
public:
CubicSplineCurve3d(
Point3dCollection^ points,
Vector3d startDerivative,
Vector3d endDerivative
)
new :
points : Point3dCollection *
startDerivative : Vector3d *
endDerivative : Vector3d -> CubicSplineCurve3d
Parameters
- points Point3dCollection
- [in] Array of points.
- startDerivative Vector3d
- [in] Starting derivative of the cubic spline curve.
- endDerivative Vector3d
- [in] Ending derivative of the cubic spline curve.
See Also