CubicSplineCurve3d Constructor

Overload List
  Name Description
Public method CubicSplineCurve3d Default constructor for the CubicSplineCurve3d class. Creates a cubic spline curve with no actual data.
Public method CubicSplineCurve3d(Point3dCollection) Constructor for the CubicSplineCurve3d class. Creates a cubic spline curve with passed points.
Public method CubicSplineCurve3d(Curve3d, Double) Constructor for the CubicSplineCurve3d class. Creates a cubic spline curve that approximates the passed curve.
Public method CubicSplineCurve3d(Point3dCollection, Tolerance) Constructor for the CubicSplineCurve3d class. Creates a cubic spline curve with the passed points.
Public method CubicSplineCurve3d(Point3dCollection, Vector3d, Vector3d) Constructor for the CubicSplineCurve3d class. Creates a cubic spline curve with the passed start and end derivatives, and points.
Public method CubicSplineCurve3d(KnotCollection, Point3dCollection, Vector3dCollection, Boolean) Constructor for the CubicSplineCurve3d class. Creates a cubic spline curve according to the passed parameters.
Public method CubicSplineCurve3d(Point3dCollection, Vector3d, Vector3d, Tolerance) Constructor for the CubicSplineCurve2d class. Creates a cubic spline curve according to the passed parameters.
Top
See Also