Curve3dGetDistanceTo(Curve3d,
Tolerance) Method
|
Retrieves the distance of the closest points
between this curve and the passed curve within a specified
tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public double GetDistanceTo(
Curve3d curve,
Tolerance tolerance
)
Public Function GetDistanceTo (
curve As Curve3d,
tolerance As Tolerance
) As Double
public:
double GetDistanceTo(
Curve3d^ curve,
Tolerance tolerance
)
member GetDistanceTo :
curve : Curve3d *
tolerance : Tolerance -> float
Parameters
- curve Curve3d
- [in] Curve to which the distance is calculated.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Double
The distance as a value of the double type.
See Also