LinkedTableDataSetCellState Method
|
Sets the cell state.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void SetCellState(
int row,
int column,
CellStates value
)
Public Overridable Sub SetCellState (
row As Integer,
column As Integer,
value As CellStates
)
public:
virtual void SetCellState(
int row,
int column,
CellStates value
)
abstract SetCellState :
row : int *
column : int *
value : CellStates -> unit
override SetCellState :
row : int *
column : int *
value : CellStates -> unit
Parameters
- row Int32
- [in] Row index of the cell.
- column Int32
- [in] Column index of the cell.
- value CellStates
- [in] Cell state.
Remarks
The method
generates the eInvalidInput exception
when the input row number and column number are less than 0 or
greater than the table size. The cell state can be one of the
following values: NameValueNone 0x00 ContentLocked 0x01 ContentReadOnly
0x02 Linked 0x04 ContentModifiedAfterUpdate 0x08 FormatLocked 0x10
FormatReadOnly 0x20 FormatModifiedAfterUpdate 0x40
See Also