Creates a viewport-independent geometric
representation of this object.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public bool WorldDraw(
WorldDraw wd
)
Public Function WorldDraw (
wd As WorldDraw
) As Boolean
public:
bool WorldDraw(
WorldDraw^ wd
)
member WorldDraw :
wd : WorldDraw -> bool
Parameters
- wd WorldDraw
- [in] World draw interface.
Return Value
Boolean
true if the geometric representation can be generated in a
viewport-independent manner, false otherwise.
Remarks
A return value of
false indicates that viewportDraw() must be called for this object.
The 3D GS will call this function at least once but may cache
subsequent display updates. Use Model::onModified() to ensure that
the 3D GS calls worldDraw() for the next display update. The
default implementation does nothing and returns true. This function
can be overridden in custom classes.
See Also