Polyline3dInsertVertexAt(ObjectId,
PolylineVertex3d) Method
|
Inserts the specified vertex entity to this
entity after the specified vertex, and makes this Polyline3d its
owner.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public ObjectId InsertVertexAt(
ObjectId indexVertexId,
PolylineVertex3d newVertex
)
Public Function InsertVertexAt (
indexVertexId As ObjectId,
newVertex As PolylineVertex3d
) As ObjectId
public:
ObjectId InsertVertexAt(
ObjectId indexVertexId,
PolylineVertex3d^ newVertex
)
member InsertVertexAt :
indexVertexId : ObjectId *
newVertex : PolylineVertex3d -> ObjectId
Parameters
- indexVertexId ObjectId
- [in] Object ID of the vertex after which to insert the
specified vertex.
- newVertex PolylineVertex3d
- [in] Vertex to insert.
Return Value
ObjectId
Returns the object ID of the newly inserted vertex.
Remarks
The vertex is made
database-resident. If this entity is not database-resident, the
vertex is made database-resident when the polyline is made
database-resident. To insert the specified vertex at the start of
this polyline, use a nullptr for indexVertexId.
See Also