Polyline3d Class

This class represents 3D polyline entities in a database.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceDrawable
          Teigha.DatabaseServicesDBObject
            Teigha.DatabaseServicesEntity
              Teigha.DatabaseServicesCurve
                Teigha.DatabaseServicesPolyline3d

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class Polyline3d : Curve, IEnumerable

The Polyline3d type exposes the following members.

Constructors
  Name Description
Public method Polyline3d Default constructor for the Polyline3d class.
Protected method Polyline3d(IntPtr, Boolean) Initializes a new instance of the Polyline3d class
Public method Polyline3d(Poly3dType, Point3dCollection, Boolean) Constructor for the Polyline3d class.
Top
Properties
  Name Description
Public property Closed Property that indicates whether this polyline is closed.
Public property Length Property that represents the length of the polyline as the sum of lengths of all its segments.
Public property PolyType Property that represents the type of the polyline. Type of the polyline: Name Value Description SimplePoly 0 Simple polyline. QuadSplinePoly 2 Quadratic B-spline fit. CubicSplinePoly 3 Cubic B-spline fit.
Top
Methods
  Name Description
Public method AppendVertex Appends the specified vertex entity to this entity, and makes this entity its owner.
Public method ConvertToPolyType Converts this 3D polyline to the specified type.
Public method GetEnumerator Returns an enumerator for traversing vertices of the entity.
Public method InsertVertexAt(ObjectId, PolylineVertex3d) Inserts the specified vertex entity to this entity after the specified vertex, and makes this Polyline3d its owner.
Public method InsertVertexAt(PolylineVertex3d, PolylineVertex3d) Inserts the specified vertex entity to this polyline entity after the specified vertex, and makes this polyline its owner.
Public method SplineFit Transforms all simple vertices to control vertices and creates new spline-fit vertices based on control vertices, through which the polyline is drawn.
Public method SplineFit(Poly3dType, Int32) Transforms all simple vertices to control vertices and creates new spline-fit vertices based on control vertices, through which the polyline is drawn.
Public method Straighten Removes all curve and spline fitting from this polyline entity.
Top
Events
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.