Cone Constructor

Overload List
  Name Description
Public method Cone Default constructor for the Cone class. Creates a cone with half angle of 45°, a reference axis of (1,0,0), a baseOrigin of (0,0,0), an axisOfSymmetry of (0,1,0), and a base radius of 2.0.
Public method Cone(Double, Double, Point3d, Double, Vector3d) Constructor for the Cone class. Creates a cone with the specified cosine and sine angles, base point, base radius and axis of symmetry.
Public method Cone(Double, Double, Point3d, Double, Vector3d, Vector3d, Interval, Double, Double) Constructor for the Cone class. Creates a cone with the specified cosine and sine angles, base point, base radius, axis of symmetry, height, and start and end angles of rotation.
Top
See Also