Cone(Double, Double, Point3d, Double, Vector3d,
Vector3d, Interval, Double, Double) Constructor
|
Constructor for the Cone class. Creates a cone
with the specified cosine and sine angles, base point, base radius,
axis of symmetry, height, and start and end angles of
rotation.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Cone(
double cosineAngle,
double sineAngle,
Point3d baseOrigin,
double baseRadius,
Vector3d axisOfSymmetry,
Vector3d referenceAxis,
Interval height,
double startAngle,
double endAngle
)
Public Sub New (
cosineAngle As Double,
sineAngle As Double,
baseOrigin As Point3d,
baseRadius As Double,
axisOfSymmetry As Vector3d,
referenceAxis As Vector3d,
height As Interval,
startAngle As Double,
endAngle As Double
)
public:
Cone(
double cosineAngle,
double sineAngle,
Point3d baseOrigin,
double baseRadius,
Vector3d axisOfSymmetry,
Vector3d referenceAxis,
Interval^ height,
double startAngle,
double endAngle
)
new :
cosineAngle : float *
sineAngle : float *
baseOrigin : Point3d *
baseRadius : float *
axisOfSymmetry : Vector3d *
referenceAxis : Vector3d *
height : Interval *
startAngle : float *
endAngle : float -> Cone
Parameters
- cosineAngle Double
- [in] Cosine angle.
- sineAngle Double
- [in] Sine angle.
- baseOrigin Point3d
- [in] Base origin.
- baseRadius Double
- [in] Base radius.
- axisOfSymmetry Vector3d
- [in] Axis of symmetry. Cone rotation is performed around this
vector.
- referenceAxis Vector3d
- [in] Reference axis that defines a zero angle of rotation.
- height Interval
- [in] Interval that limits cone volumes.
- startAngle Double
- [in] Start angle of rotation.
- endAngle Double
- [in] End angle of rotation.
See Also