Cone Class

This .NET class wraps the OdGeCone class.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometrySurface
          Teigha.GeometryCone

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class Cone : Surface

The Cone type exposes the following members.

Constructors
  Name Description
Public method Cone Default constructor for the Cone class. Creates a cone with half angle of 45°, a reference axis of (1,0,0), a baseOrigin of (0,0,0), an axisOfSymmetry of (0,1,0), and a base radius of 2.0.
Public method Cone(Double, Double, Point3d, Double, Vector3d) Constructor for the Cone class. Creates a cone with the specified cosine and sine angles, base point, base radius and axis of symmetry.
Public method Cone(Double, Double, Point3d, Double, Vector3d, Vector3d, Interval, Double, Double) Constructor for the Cone class. Creates a cone with the specified cosine and sine angles, base point, base radius, axis of symmetry, height, and start and end angles of rotation.
Top
Properties
  Name Description
Public property Apex  
Public property AxisOfSymmetry  
Public property BaseCenter  
Public property BaseRadius  
Public property HalfAngle  
Public property Height  
Public property IsOuterNormal  
Public property ReferenceAxis  
Top
Methods
  Name Description
Public methodStatic member Create Creates a Cone object based on the passed pointer.
Public method GetAngles Retrieves angles of rotation for this cone.
Public method GetHalfAngles Retrieves half angles that define this cone. Absolute values of angles are retrieved (i.e. any signs are dropped).
Public method GetHeightAt Retrieves the height of this cone corresponding to the specified position on the U-axis.
Public method IntersectWith(LinearEntity3d) Retrieves intersection points between this cone and the passed linear entity.
Public method IntersectWith(LinearEntity3d, Tolerance) Retrieves intersection points between this cone and the passed linear entity. Calculations are performed within the specified tolerance.
Public method IsClosed Checks whether the base of this cone is a full circle.
Public method IsClosed(Tolerance) Checks whether the base of this cone is a full circle within the specified tolerance.
Public method Set(Double, Double, Point3d, Double, Vector3d) Sets the parameters for this cone according to the arguments.
Public method Set(Double, Double, Point3d, Double, Vector3d, Vector3d, Interval, Double, Double) Sets the parameters for this cone according to the arguments.
Public method SetAngles Sets the start and end angles of rotation for this cone.
Top
See Also

©  Bricsys NV. All rights reserved.