Services Class

The class for providing services at runtime.
Inheritance Hierarchy
SystemObject
  Teigha.RuntimeServices

Namespace: Teigha.Runtime
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class Services : IDisposable

The Services type exposes the following members.

Constructors
  Name Description
Public method Services Constructor for the Services class. Calls the Init() method for a newly created object.
Top
Properties
  Name Description
Public propertyStatic member Current Provides access to current Services.
Top
Methods
  Name Description
Public method AccessFileRead Checks whether a specified file can be accessed for read operations.
Public method Dispose Destructor for the Services class. Calls the UnInit() method for the object that is about to be destroyed.
Protected method Dispose(Boolean) Releases the unmanaged resources used by the Services and optionally releases the managed resources
Protected method Finalize Calls the UnInit() method for this object.
(Overrides ObjectFinalize)
Public method LoadArchitecture Loads 3 architecture .NET Classic wrappers libraries: TA_Mgd, TA_MgdArch, TA_MgdStructure.
Public methodStatic member odActivate Sets user activation data.
Top
See Also

©  Bricsys NV. All rights reserved.