SelectionReactor Class

This class is the base class for custom classes that receive notification of selection events from the graphics system.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GraphicsSystemSelectionReactor

Namespace: Teigha.GraphicsSystem
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class SelectionReactor : DisposableWrapper

The SelectionReactor type exposes the following members.

Constructors
  Name Description
Public method SelectionReactor Default constructor for the SelectionReactor class.
Protected method SelectionReactor(IntPtr, Boolean) Initializes a new instance of the SelectionReactor class
Top
Properties
  Name Description
Top
Methods
  Name Description
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public method Selected(DrawableDesc) Notification function called whenever an OdGiDrawableDesc object has been selected.
Public method Selected(PathNode, Viewport)  
Top
Remarks
For code examples, see derived class SR (NetClassic/Examples/OdaMgdApp/SelectionReactor.cs) and its usage in a snap manager of OdaMgdApp, in the PickEntitiesAtCurrentScreenPoint method (NetClassic/Examples/OdaMgdApp/SnapPoints/SnapManager.cs)
See Also

©  Bricsys NV. All rights reserved.