DisposableWrapper Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      More

Namespace: Teigha.Runtime
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class DisposableWrapper : MarshalByRefObject, 
        IDisposable

The DisposableWrapper type exposes the following members.

Constructors
  Name Description
Protected method DisposableWrapper Initializes a new instance of the DisposableWrapper class
Protected method DisposableWrapper(IntPtr, Boolean) Initializes a new instance of the DisposableWrapper class
Top
Properties
  Name Description
Public property AutoDelete  
Public property IsDisposed  
Public property UnmanagedObject  
Top
Methods
  Name Description
Public methodStatic member Create  
Protected method DeleteUnmanagedObject  
Public method Dispose Releases all resources used by the DisposableWrapper
Protected method Dispose(Boolean) Releases the unmanaged resources used by the DisposableWrapper and optionally releases the managed resources
Public method Equals
(Overrides ObjectEquals(Object))
Protected method Finalize
(Overrides ObjectFinalize)
Public method GetHashCode
(Overrides ObjectGetHashCode)
Top
Operators
See Also
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.ApplicationServicesDocument
      Bricscad.ApplicationServicesDocumentIterator
      Bricscad.ApplicationServicesInplaceTextEditor
      Bricscad.ApplicationServicesInplaceTextEditorSettings
      Bricscad.ApplicationServicesSettings
      Bricscad.ApplicationServicesXrefFileLock
      Bricscad.BimBIMAssets
      Bricscad.BimBIMClassification
      Bricscad.BimBIMDialogs
      Bricscad.BimBIMInformationalAssets
      Bricscad.BimBIMLinearGeometry
      Bricscad.BimBIMObject
      Bricscad.BimBIMPhysicalAssets
      Bricscad.BimBIMPolicies
      Bricscad.BimBIMProfile
      Bricscad.CivilGisFeatureAttribute
      Bricscad.CivilGisFeatureAttributeData
      Bricscad.CivilGisFeatureAttributeDefinition
      Bricscad.CivilGisLayerDefinition
      Bricscad.CivilGisTable
      Bricscad.CivilGradingRule
      Bricscad.CivilStationEquation
      Bricscad.CivilStationEquationCollection
      Bricscad.CivilTinSurfaceConstraint
      Bricscad.CivilTinSurfaceDensify
      Bricscad.CivilTinSurfaceObject
      Bricscad.CivilTinSurfaceSimplify
      Bricscad.DirectModelingAuditFlaw
      Bricscad.DirectModelingAuditOperation
      Bricscad.DirectModelingAuditReport
      Bricscad.DirectModelingModelerThreadLock
      Bricscad.EditorInputSelectionSet
      Bricscad.GraphicsSystemGraphicsKernel
      Bricscad.GraphicsSystemKernelDescriptor
      Bricscad.GraphicsSystemManager
      Bricscad.GraphicsSystemUniqueString
      Bricscad.HlrHlrCollector
      Bricscad.HlrHlrData
      Bricscad.HlrHlrEngine
      Bricscad.IfcExportContext
      Bricscad.IfcIfcBinary
      Bricscad.IfcIfcEntity
      Bricscad.IfcIfcEntityDesc
      Bricscad.IfcIfcEnumValue
      Bricscad.IfcIFCExportOptions
      Bricscad.IfcIFCExportReactor
      Bricscad.IfcIfcGuid
      Bricscad.IfcIfcHeader
      Bricscad.IfcIFCImportReactor
      Bricscad.IfcIfcLogical
      Bricscad.IfcIfcModel
      Bricscad.IfcIfcSelectorDesc
      Bricscad.IfcIfcSelectValue
      Bricscad.IfcIfcString
      Bricscad.IfcIfcVectorDesc
      Bricscad.IfcIfcVectorValue
      Bricscad.IfcImportContext
      Bricscad.IfcImportInfo
      Bricscad.MechanicalComponentsComponentDefinition
      Bricscad.MechanicalComponentsComponentInstance
      Bricscad.ParametricConstraint3d
      Bricscad.ParametricConstraintsGroup3d
      Bricscad.ParametricDesignTable
      Bricscad.ParametricDesignTableConfiguration
      Bricscad.ParametricDesignTableConfigurationEntry
      Bricscad.ParametricParameter
      Bricscad.PlottingServicesDsdData
      Bricscad.PlottingServicesDsdEntry
      Bricscad.PlottingServicesDsdEntryCollection
      Bricscad.PlottingServicesPlotEngine
      Bricscad.PlottingServicesPlotLogger
      Bricscad.PlottingServicesPlotProgress
      Bricscad.PublishingDwf3dNavigationTreeNode
      Bricscad.QuadQuadBoundary
      Bricscad.QuadQuadItemRegistry
      Bricscad.QuadQuadItems
      Bricscad.QuadQuadReactor
      Bricscad.QuadQuadSelection
      Bricscad.QuadQuadSelectionData
      Bricscad.WindowsRibbonControl
      Bricscad.WindowsRibbonItem
      Bricscad.WindowsRibbonPanel
      Bricscad.WindowsRibbonPanelSource
      Bricscad.WindowsRibbonTab
      Bricscad.WindowsStatusBarItem
      Bricscad.WindowsTrayItemBubbleWindow
      Bricscad.WindowsWindow
      Teigha.Aec.ModelerEntity
      Teigha.BoundaryRepresentationBrepEntity
      Teigha.BoundaryRepresentationEnumeratorBase
      Teigha.BoundaryRepresentationHit
      Teigha.BoundaryRepresentationMesh2dFilter
      Teigha.BoundaryRepresentationMeshControl
      Teigha.BoundaryRepresentationMeshEntity
      Teigha.ColorsColor
      Teigha.DatabaseServicesAssoc2dConstraintCallback
      Teigha.DatabaseServicesAssocEvaluationCallback
      Teigha.DatabaseServicesAssocVariableCallback
      Teigha.DatabaseServicesAuditInfo
      Teigha.DatabaseServicesBlockPropertiesTableAuditError
      Teigha.DatabaseServicesBlockTableRecordEnumerator
      Teigha.DatabaseServicesDataCellCollection
      Teigha.DatabaseServicesDbHomeView
      Teigha.DatabaseServicesDBObjectCollection
      Teigha.DatabaseServicesDynamicBlockReferencePropertyCollection
      Teigha.DatabaseServicesDynamicDimensionData
      Teigha.DatabaseServicesDynamicDimensionDataCollection
      Teigha.DatabaseServicesFileDependencyManager
      Teigha.DatabaseServices.FiltersFilteredBlockIterator
      Teigha.DatabaseServices.FiltersIndexUpdateData
      Teigha.DatabaseServicesGeoCoordinateCategory
      Teigha.DatabaseServicesGeoCoordinateSystem
      Teigha.DatabaseServicesGeoCoordinateTransformer
      Teigha.DatabaseServicesGraph
      Teigha.DatabaseServicesGraphNode
      Teigha.DatabaseServicesGraphNodeCollection
      Teigha.DatabaseServicesGripData
      Teigha.DatabaseServicesGripDataCollection
      Teigha.DatabaseServicesHyperLink
      Teigha.DatabaseServicesHyperLinkCollection
      Teigha.DatabaseServicesLoftOptions
      Teigha.DatabaseServicesMTextFragment
      Teigha.DatabaseServicesObjectIdCollection
      Teigha.DatabaseServicesPlotSettingsValidator
      Teigha.DatabaseServicesPointCloudCrop
      Teigha.DatabaseServicesResultBuffer
      Teigha.DatabaseServicesRevolveOptions
      Teigha.DatabaseServicesSweepOptions
      Teigha.DatabaseServicesSymbolTableEnumerator
      Teigha.DatabaseServicesUnderlayFile
      Teigha.DatabaseServicesUnderlayItem
      Teigha.DatabaseServicesUnderlayLayer
      Teigha.DatabaseServicesXrefFullSubentityPath
      Teigha.Export_ImportDWFImageResource
      Teigha.Export_ImportDWFPageData
      Teigha.Export_ImportmDwf3dExportParams
      Teigha.Export_ImportmDwfExportParams
      Teigha.Export_ImportmPDFExportParams
      Teigha.GeometryCurve2dCollection
      Teigha.GeometryCurve3dCollection
      Teigha.GeometryCurveBoundary
      Teigha.GeometryEntity2d
      Teigha.GeometryEntity3d
      Teigha.GeometryInterval
      Teigha.GeometryKnotCollection
      Teigha.GeometryPoint2dCollection
      Teigha.GeometryPoint3dCollection
      Teigha.GraphicsInterfaceAbstractClipBoundary
      Teigha.GraphicsInterfaceClipBoundary
      Teigha.GraphicsInterfaceImageBGRA32
      Teigha.GraphicsInterfaceLinetypeCollection
      Teigha.GraphicsInterfacePathNode
      Teigha.GraphicsInterfaceTransientManager
      Teigha.GraphicsInterfaceTtfDescriptor
      Teigha.GraphicsSystemPageParams
      Teigha.GraphicsSystemSelectionReactor
      Teigha.ModelerGeometryTriangulationParams
      Teigha.RuntimeProgressMeter
      Teigha.RuntimeRXObject

©  Bricsys NV. All rights reserved.