MatchPropertiesCopyProperties Method
|
Copies the specified properties from the
source entity to the destination entity.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void CopyProperties(
Entity sourceEntity,
Entity targetEntity,
int flag
)
Public Overridable Sub CopyProperties (
sourceEntity As Entity,
targetEntity As Entity,
flag As Integer
)
public:
virtual void CopyProperties(
Entity^ sourceEntity,
Entity^ targetEntity,
int flag
)
abstract CopyProperties :
sourceEntity : Entity *
targetEntity : Entity *
flag : int -> unit
override CopyProperties :
sourceEntity : Entity *
targetEntity : Entity *
flag : int -> unit
Parameters
- sourceEntity Entity
- [in] Source entity.
- targetEntity Entity
- [in] Target entity.
- flag Int32
- [in] Flag that represents properties to copy.
Remarks
The flag parameter must be a combination of one or more
of the following values: NameValuePropertykColorFlag
0x00001 Color kLayerFlag 0x00002 Layer kLtypeFlag 0x00004 Linetype
kThicknessFlag 0x00008 Thickness kLtscaleFlag 0x00010 Linetype
scale kTextFlag 0x00020 Text kDimensionFlag 0x00040 Dimension
kHatchFlag 0x00080 Hatch kLweightFlag 0x00100 Lineweight
kPlotstylenameFlag 0x00200 Plotstyle name kPolylineFlag 0x00400
Polyline kViewportFlag 0x00800 Viewport kTableFlag 0x01000 Table
kMaterialFlag 0x02000 Material kShadowDisplayFlag 0x04000 Shadow
display kMultileaderFlag 0x08000 Multileader kTransparencyFlag
0x10000 Transparency kSetAllFlagsOn 0x1FFFF All
See Also