Entity Class |
The Entity type exposes the following members.
Name | Description | |
---|---|---|
![]() |
![]() |
![]() |
![]() |
BlockId | Property that represents an object identifier of a block that stores this entity. |
![]() |
BlockName | Property that represents the name of a block that owns this entity. |
![]() |
![]() |
CastShadows | Property that indicates whether this entity casts shadows. |
![]() |
![]() |
CloneMeForDragging | Property that represents the cloneMeForDragging flag. This flag indicates whether a clone of this entity should be created for drag operations. |
![]() |
CollisionType | Property that represents a collision type for this entity. |
![]() |
Color | Property that represents color for this entity. |
![]() |
ColorIndex | Property that represents a color index for this entity. |
![]() |
CompoundObjectTransform | Property that represents a transformation matrix for compound objects (these objects return the DrawableIsCompoundObject flag from the subSetAttributes() method). The returned matrix is the same matrix that is passed to pushModelTransform() before rendering nested objects. |
![]() |
![]() |
![]() |
![]() |
Ecs | Property that represents the entity coordinate system matrix. |
![]() |
EdgeStyleId | Property that represents an object identifier of an edge style. |
![]() |
EntityColor | Property that represents an entity color value for this entity. |
![]() |
![]() |
FaceStyleId | Property that represents an object identifier of a face style. |
![]() |
ForceAnnoAllVisible | |
![]() |
GeometricExtents | Property that represents geometric extents for this entity. |
![]() |
![]() |
![]() |
![]() |
Hyperlinks | Property that represents a collection of hyperlinks associated with this entity. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
IsPlanar | Property that indicates whether this entity is planar. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Layer | Property that represents a layer name for this entity. |
![]() |
LayerId | Property that represents an object identifier of a layer for this entity. |
![]() |
Linetype | Property that represents the linetype attribute for this entity. |
![]() |
LinetypeId | Property that represents a linetype attribute for this entity. |
![]() |
LinetypeScale | Property that represents a scale factor of a linetype for this entity. |
![]() |
LineWeight | Property that represents a lineweight attribute for this entity. |
![]() |
Material | Property that represents a material for this entity. |
![]() |
MaterialId | Property that represents an object identifier of a material for this entity. |
![]() |
MaterialMapper | Property that represents a material mapper for this entity. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
PlotStyleName | Property that represents the plot style name for this entity. |
![]() |
PlotStyleNameId | Property that represents a descriptor of the plot style used for this entity. |
![]() |
ReceiveShadows | Property that indicates whether this entity receives shadows. |
![]() |
Transparency | Property that represents the transparency attribute for this entity. |
![]() |
![]() |
![]() |
Visible | Property that indicates whether this entity is visible. |
![]() |
VisualStyleId | Property that represents an object identifier of a visual style. |
![]() |
Name | Description | |
---|---|---|
![]() |
![]() |
![]() |
AddSubentityPaths | Adds one or more subentities to this entity. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. Calculates the bounding box for this entity and then finds the intersections of the passed entity and all the edges of the bounding box of this entity. |
![]() |
BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | Calculates the bounding box for this entity and then finds the intersections of the passed entity and all the edges of the bounding box of this entity. |
![]() |
BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. Projects the bounding box edges of this entity and the passed entity on the projection plane, calculates the bounding box for this entity, and then finds the intersection points and projects intersections back to the bounding box edge of this entity. |
![]() |
BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | Projects the bounding box edges of this entity and the passed entity on the projection plane, calculates the bounding box for this entity, and then finds the intersection points and projects intersections back to the bounding box edge of this entity. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
DeleteSubentityPaths | Removes one or more subentities from this entity. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Draw | Queues up the entity's graphics and flushes the graphics queue, forcing the queue elements to be drawn or re-drawn. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Explode | Explodes this entity into a set of simpler entities. |
![]() |
ExplodeGeometry | Explodes this entity into a set of simpler entities. |
![]() |
ExplodeGeometryToBlock(BlockTableRecord) | Explodes this entity into a set of simpler entities and adds them to the specified block. |
![]() |
ExplodeGeometryToBlock(BlockTableRecord, ObjectIdCollection) | Explodes this entity into a set of simpler entities and adds them to the specified block. |
![]() |
ExplodeGeometryToOwnerSpace | Explodes this entity into a set of simpler entities and adds them to the owner block. |
![]() |
![]() |
![]() |
![]() |
![]() |
GetGraphicsMarkersAtSubentityPathIntPtr | Entities use a mechanism of graphics system markers to draw themselves. This mechanism associates an integer identifier called a graphics system marker (or, GS marker) with each primitive or with groups of primitives. Using specific selection mechanisms, the GS marker for the actual subentity selected on the screen can be retrieved and used for various purposes, for example highlighting/unhighlighting the subentity on the screen, hiding/unhiding it, etc. This method returns all graphics system markers by subentity paths for complex entities that have the ability to associate an integer identifier (GS marker) with each graphics primitive or with groups of primitives during the draw. |
![]() |
GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | Returns all grip points of this entity. |
![]() |
GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | Returns all grip points of this entity. |
![]() |
GetGripPointsAtSubentityPath | Gets the grip points and supporting information about the grips for a subentity. |
![]() |
![]() |
![]() |
![]() |
![]() |
GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | Returns all appropriate object snap points of this entity. |
![]() |
GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | Returns all appropriate object snap points of this entity. |
![]() |
![]() |
GetPlane | Returns the plane on which this entity lies. |
![]() |
![]() |
![]() |
GetStretchPoints | Returns all stretch points of this entity. |
![]() |
GetSubentity | Returns a subentity specified by its full path. |
![]() |
GetSubentityGeometricExtents | Returns the geometric extents for a subentity. |
![]() |
GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, ObjectId) | Returns all subentity paths by the graphic system marker for complex entities that have the ability to associate an integer identifier (GS marker) with each graphic primitive or with groups of primitives during drawing. |
![]() |
GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, ObjectId) | Obsolete. Returns all subentity paths by the graphics system marker for complex entities that have the ability to associate an integer identifier (GS marker) with each graphic primitive or with groups of primitives during drawing. |
![]() |
GetTransformedCopy | Creates a copy of this entity, applies the passed transformation to the newly created copy, and returns the copy. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Highlight | Highlights this entity. |
![]() |
Highlight(FullSubentityPath, Boolean) | Highlights the specified subentity path for this entity. |
![]() |
![]() |
IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. Intersects this entity with another entity if possible. |
![]() |
IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | Intersects this entity with another entity if possible. |
![]() |
IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. Projects this entity on the specified plane, calculates intersection points with the specified entity, and projects intersection points back to the entity. |
![]() |
IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | Projects this entity on the specified plane, calculates intersection points with the specified entity, and projects intersection points back to the entity. |
![]() |
IsContentSnappable | Checks whether the containing block is to be investigated for osnaps (object snapping) points. |
![]() |
JoinEntities | |
![]() |
JoinEntity | |
![]() |
List | This method is triggered by the standard LIST command and displays the DXF format contents of the entity to the display. |
![]() |
![]() |
![]() |
MoveGripPointsAt(IntegerCollection, Vector3d) | Moves the specified grip points of this entity. |
![]() |
MoveGripPointsAt(GripDataCollection, Vector3d, MoveGripPointsFlags) | Applies a vector offset to one or more grip points. |
![]() |
MoveGripPointsAtSubentityPaths | Applies a vector offset to one or more grip points exposed by the subentities of the object. |
![]() |
MoveStretchPointsAt | Moves the specified stretch points of this entity. |
![]() |
![]() |
RecordGraphicsModified | Sets the bit flag indicating that the entity's geometry is changed. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
SaveAs | Creates a geometric representation of this entity for saving proxy graphics or converting to previous formats. |
![]() |
![]() |
SetDatabaseDefaults | Applies the default properties to this entity from the database where this entity is stored or from the host application database. |
![]() |
SetDatabaseDefaults(Database) | Applies the default properties to this entity from the specified database. |
![]() |
SetDragStatus | Notification function called when this entity is involved in a drag operation. |
![]() |
![]() |
![]() |
![]() |
SetGripStatus | Notification function called when this entity is involved in a grip operation. |
![]() |
SetLayerId | Sets the layer to be referenced by this entity (DXF 8). |
![]() |
![]() |
![]() |
SetPropertiesFrom | Creates a geometric representation of this entity for saving proxy graphics or converting to previous formats. |
![]() |
SetSubentityGripStatus | The notification method called just before grips for the subentity are deleted from the host application. The status parameter indicates that the grips for the entity have been deleted from the host application and the entity does not participate in any grip edit operations. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
SwapReferences | This method performs object ID reference translations similar
to those done at the end of deep cloning. References between
objects in the workset have their object identifiers translated to
the swapped object identifiers of the referenced objects. In
contrast to cloning, this translation must occur in both
directions. Accordingly, it is possible to pass two different ID
![]() |
![]() |
TransformBy | Applies the specified 3D transformation matrix to this entity. |
![]() |
TransformSubentityPathsBy | Applies a geometric transformation to one or more subentities of an object. |
![]() |
Unhighlight | Unhighlights this entity. |
![]() |
Unhighlight(FullSubentityPath, Boolean) | Unhighlights the specified subentity path for this entity. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Name | Description | |
---|---|---|
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
© Bricsys NV. All rights reserved. |