FullSubentityPathEquals Method
|
Checks objects for equality.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public override sealed bool Equals(
Object obj
)
Public Overrides NotOverridable Function Equals (
obj As Object
) As Boolean
public:
virtual bool Equals(
Object^ obj
) override sealed
abstract Equals :
obj : Object -> bool
override Equals :
obj : Object -> bool
Parameters
- obj Object
- [in] Object to check for equality.
Return Value
Boolean
true if the passed object is not null,
has the same subentity ID, an array of entities that define the
path to the entity containing the searched subentity and the array
length.
Remarks
For Equals and GetHashCode
methods, an override should be completed together to match logic;
if Equals returns true, hashcodes should be the same; the same
hashcodes do not always mean that the objects are the same because
of collisions; hashcodes should be formed for fields on which
equality is based; sometimes the Equals
method is taken from a C++ object, but since pointers are compared,
you still can use GetHashCode from here,
while Equals can be overridden in a
derived class.
See Also