SubDMeshConvertToSurface(Boolean,
SubentityId) Method
|
Creates a new surface object from a part of
this mesh by using the specified sub-entity ID.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Surface ConvertToSurface(
bool convertAsSmooth,
SubentityId subentId
)
Public Function ConvertToSurface (
convertAsSmooth As Boolean,
subentId As SubentityId
) As Surface
public:
Surface^ ConvertToSurface(
bool convertAsSmooth,
SubentityId subentId
)
member ConvertToSurface :
convertAsSmooth : bool *
subentId : SubentityId -> Surface
Parameters
- convertAsSmooth Boolean
- [in] Flag that specifies whether to convert to a smooth
surface. If false, converts to a faceted surface.
- subentId SubentityId
- [in] Sub-entity ID to convert.
Return Value
Surface
Surface object converted from this SubDMesh.
See Also