Solid3dTransformFaces Method
|
Transforms the specified faces of a solid by
applying a transformation matrix.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void TransformFaces(
SubentityId[] subentityIds,
Matrix3d matrix
)
Public Overridable Sub TransformFaces (
subentityIds As SubentityId(),
matrix As Matrix3d
)
public:
virtual void TransformFaces(
array<SubentityId>^ subentityIds,
Matrix3d matrix
)
abstract TransformFaces :
subentityIds : SubentityId[] *
matrix : Matrix3d -> unit
override TransformFaces :
subentityIds : SubentityId[] *
matrix : Matrix3d -> unit
Parameters
- subentityIds SubentityId
- [in] Face's subentity ID in the solid.
- matrix Matrix3d
- [in] Transformation matrix.
Remarks
Transforming faces
can cause the solid to become invalid in some cases. This method is
implemented only for the Spatial modeler.
See Also