Introduces a ray into the vectorization
context.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public abstract bool Ray(
Point3d point1,
Point3d point2
)
Public MustOverride Function Ray (
point1 As Point3d,
point2 As Point3d
) As Boolean
public:
virtual bool Ray(
Point3d point1,
Point3d point2
) abstract
abstract Ray :
point1 : Point3d *
point2 : Point3d -> bool
Parameters
- point1 Point3d
- [in] Base point.
- point2 Point3d
- [in] Point through which a ray passes.
Return Value
Boolean
true. This method also throws a corresponding exception if it
fails.
Remarks
A ray is a
semi-infinite line that starts at the basePoint and passes through
the throughPoint. The ray takes on the current color.
See Also